Skip to main content
FluidEarth Portal Header version 3

FluidEarth Portal

Go Search
  
FluidEarth Portal > FluidEarth Discussions > Problems when running the BdyFtn+WriterCVS example in Pipistrelle  

FluidEarth Discussions

Modify settings and columns
Discussions board for FluidEarth Users
  
View: 
Post
Started: 30/10/2010 17:04
Picture Placeholder: MNalesso
MNalesso
Problems when running the BdyFtn+WriterCVS example in Pipistrelle
Hello
 
I'm starting with the use of the Pipistrelle interface so I started with the example from the e-learning video but when I run the composition I found the following error:
6: An attempt was made to load a program with an incorrect format. (Exception from HRESULT: 0x8007000B)
 
I'm using Visual Studio 2008 to build the solution for the BdyFtn program
 
Thank you!
Posted: 30/10/2010 17:49
Picture Placeholder: GGlasgow
GGlasgow
Hi,
 
it sounds to me as though this may be being caused by incompatible bitness - the precompiled sdk we have uploaded to the portal is 32 bit, so if you've compiled your solution 64 bit you might get this problem.
 
as a quick check, could you take a look at your solution to see if it is currently compiled 64 bit? if this is the case, try recompiling as 32 bit and rerunning your composition. if this solves your problem but you actually want a 64 bit component, we can upload a 64bit sdk dll for you to test with. if not, we can look at other possibilities for this error.
 
let me know how you get on,
 
gordon
Posted: 30/10/2010 22:10
Picture Placeholder: MNalesso
MNalesso
Hi
 
Thank you for answer
 
No, the solution was compiled on 32bit
 
Mauro.
Posted: 31/10/2010 09:50
Picture Placeholder: GGlasgow
GGlasgow
ok, will have to think about other possibilities. will have a word with Adrian our developer on Monday, and let you know his thoughts.
 
to help work out where the problem lies, have you been able to run any of the precompiled models on your machine - either the binaries uploaded to the elearning folder, or the examples within the Pipistrelle repository?
 
also, does your problem start when you try to compile and run the solutions from the elearning folder, or only when you put together a new solution?
 
gordon
Posted: 01/11/2010 13:45
Attachment
Picture Placeholder: MNalesso
MNalesso
Hi
 
I have been able to run the models from the Pipistrelle repository, from the BIN folder I only could download this model.
 
I tried to run only the BdyFtn model without the CsvWriter and I'm attaching the list of errors that appears.
 
Thank you
 
Mauro.
Posted: 01/11/2010 14:00
Attachment
Picture Placeholder: GGlasgow
GGlasgow
Hi,
 
sorry - i thought i had uploaded precomiled models in the bin folder, it appears as though they are the solutions with no executables.
i've attached to this reply a zip containing a compiled version of the bdyftn solution (this time vs2008 rather than 2005), which includes binaries.
 
can you check if you can use the binaries in the attached (remembering to load the .omi file from the \bin\data\ folder)? if this works, can you check whetehr you can successfully compile the solution on your own machine and use the resulting binaries?
 
thanks,
 
gordon
Posted: 01/11/2010 16:11
Picture Placeholder: MNalesso
MNalesso
Hi
 
I can't download the zip file, it appears the message that tell to request permision to do it, can you please give me acces to the file?
Thank you again
 
Mauro.
Posted: 01/11/2010 16:18
Attachment
Picture Placeholder: GGlasgow
GGlasgow
sorry about that - i still can't work out what sharepoint will and won't allow re file extensions.
 
to this message, attached the same file sans the extension - append .zip and it should work.
 
gordon