Skip to main content
FluidEarth Portal Header version 3

FluidEarth Portal

Go Search
  
FluidEarth Portal > FluidEarth Discussions > Assertion Failed error  

FluidEarth Discussions

Modify settings and columns
Discussions board for FluidEarth Users
  
View: 
Post
Started: 26/05/2010 14:09
Attachment
Picture Placeholder: MMansour
MMansour
Assertion Failed error
I followed the SDK video tutorial to create an empty solution in C#. The solution builds successfully; however, when I import the model to Pipistrelle I get an assertion error message (attached).  I tried the process twice and got the same problem. I run the Empty_cs project successfully in Pipistrelle and wonder what an I doing wrong in my project. Can you help please?  Thanks.
Posted: 26/05/2010 14:27
Attachment
Picture Placeholder: GGlasgow
GGlasgow
hi,
 
...i think this one's all my fault!
 
what i guess is happening is that your C# project is compiled 'debug' but the SDK you are using (the one i compiled for the workshop) was compiled release. this happened a couple of times on the workshop too, and caused a pretty big error.
 
to get around it, go back to your project and select 'release' from the build options (see attached jpg) and then reload the model into pipistrelle.
 
if this doesn't fix the problem, you might need to check that your release and debug builds are going to the same folder so that you are not still using the old binaries.
 
hope this helps - let me know if not.
 
gordon
Posted: 26/05/2010 14:40
Picture Placeholder: MMansour
MMansour
Thanks Gordon.  It works now.  I simply built the solution in release mode and no complaints in Pipistrelle.