Skip to main content
FluidEarth Portal Header version 3

FluidEarth Portal

Go Search
  
FluidEarth Portal > FluidEarth Discussions > Pipistrelle error message of new solution > Pipistrelle error message of new solution  

FluidEarth Discussions: Pipistrelle error message of new solution

Body

hi,
 
glad i could be some help.
 
could you rerun your pipistrelle composition with 'Event Monitoring' set to 'All' and 'Logging Level' set to 'Debug 2' and attach a copy of the full log file? pipistrelle has very comprehensive event logging, which can be very helpful when debugging, but it can be tricky to see where things have first started to go wrong. if you attach your full log file, i will quickly go through it and point out the most important things to look out for when things go wrong.
 
good luck!
 
gordon

From: ZZhang
Posted: 15 March 2010 22:33
Subject: Pipistrelle error message of new solution

Hi Gordon,
 
You gave me very useful advice. Somes projects' output path were changed after I  reload them.
 
I got another issue. I try to built a new Solution to write output data from the 2D-sample.
But whne I run the Pipistrelle, I got error message as following:

2010-03-15T22:24:38,Error   , 2052,Write F  (C),Exception:
    _engine.Initialise(...) return value < 0
  Source:
    "OpenWEB_SDK"
  Target:
    targetSite unknown
  Stack:
   at OpenWeb.Sdk.ServerBase5.Initialise(String sdkConfigFileContents, Int32 arraySizeIn, Int32 arraySizeOut, Double[]& dataOut, String& log) in E:\OPENMI\OpenWEB\OpenWEB_SDK\src\ServerBase5.cs:line 495
2010-03-15T22:24:38,Error   , 2052,Write F  (C),Exception:
    ServerBase.Initialise(...)
  Source:
    ""
  Target:
    targetSite unknown
  Stack:
stackTrace unknown
2010-03-15T22:24:38,Error   , 2052,Write F  (C),Exception:
    time = Initialise(...), time < 0
  Source:
    "OpenWEB_SDK"
  Target:
    Double Initialise(System.Collections.Generic.Dictionary`2[System.String,System.String], OpenWeb.Sdk.ILinkage, System.Collections.Generic.List`1[OpenWeb.Sdk.DataOperations.IDataOperationRuntimeFactory])
  Stack:
   at OpenWeb.Sdk.EngineProxy.Initialise(Dictionary`2 properties, ILinkage linkage, List`1 dataOperationFactories) in E:\OPENMI\OpenWEB\OpenWEB_SDK\src\EngineProxy.cs:line 304
   at OpenWeb.Sdk.EngineClient.Initialize(Dictionary`2 properties, ILinkableComponent linkableComponent, ILinkage linkage, List`1 dataOperationFactories, ILogger logger) in E:\OPENMI\OpenWEB\OpenWEB_SDK\src\EngineClient.cs:line 309
2010-03-15T22:24:38,Error   , 2052,Write F  (C),Exception:
    _engineProxy.Initialise(...)
  Source:
    "OpenWEB_SDK"
  Target:
    Void Initialize(System.Collections.Generic.Dictionary`2[System.String,System.String], OpenMI.Standard.ILinkableComponent, OpenWeb.Sdk.ILinkage, System.Collections.Generic.List`1[OpenWeb.Sdk.DataOperations.IDataOperationRuntimeFactory], OpenWeb.Sdk.ILogger)
  Stack:
   at OpenWeb.Sdk.EngineClient.Initialize(Dictionary`2 properties, ILinkableComponent linkableComponent, ILinkage linkage, List`1 dataOperationFactories, ILogger logger) in E:\OPENMI\OpenWEB\OpenWEB_SDK\src\EngineClient.cs:line 313
   at OpenWeb.Sdk.LinkableComponent.Prepare() in E:\OPENMI\OpenWEB\OpenWEB_SDK\src\LinkableComponent.cs:line 554

I donot know the mean of the message.  Can you give me some advice.
Attachments
Content Type: Message
Created at 16/03/2010 08:36  by GGlasgow 
Last modified at 16/03/2010 08:36  by GGlasgow