Skip to main content
FluidEarth Portal Header version 3

FluidEarth Portal

Go Search
  
FluidEarth Portal > FluidEarth Discussions > Two questions > Two questions  

FluidEarth Discussions: Two questions

Body

Hi Gordon,
 
I have built the code as release vesion, but the assert dialog still appear. And I donot really understand the solution in the manual. After adding a break point, attach to process and then click Ignore button, it doesnot stop at the break point.
If I click "Retry" ,it stop on the line "Debug.Assert(!assert):"(in EngineProxy.cs).
So I donot how to handle this. And I also donot why the Assert dialog comes out.
 




From: GGlasgow
Posted: 07 March 2010 08:34
Subject: Two questions

Hi,
 
the first of your issues isn't really a problem - you have compiled your code as 'debug' in visual studio; this 'assertion failed' dialog is your chance to step into the code to debug. there's some advice on this in the manual/guide and if you aren't trying to debug at this time, you can compile your code as 'release' in VS and it shouldn't appear. if you do this and are still having problems, let me know.
i'll put together a sample code that exchanges an array of data that will show you how to solve the second problem. i'll post the code as a second reply.
 
good luck with your wrapping,
 
gordon

From: ZZhang
Posted: 03 March 2010 22:19
Subject: Two questions

Dear,

 

I have two questions as the attachment.
 

If I make you misunderstand, please feel free to contact me.

My email: gulley@163.com

 

I really appreciate if someone can handle these problems for me.

Attachments
Content Type: Message
Created at 15/03/2010 12:37  by ZZhang 
Last modified at 15/03/2010 12:37  by ZZhang