Skip to main content
FluidEarth Portal Header version 3

FluidEarth Portal

Go Search
  
FluidEarth Portal > FluidEarth Discussions > DLL missing when I try to copy Fluid Earth example > DLL missing when I try to copy Fluid Earth example  

FluidEarth Discussions: DLL missing when I try to copy Fluid Earth example

Body

Hi Ed, Thanks for the detailed info. I'll be looking into this as soon as possible.  If you get a chance to try again from scratch it might be worth doing but in the meantime I'll be trying to duplicate the problem.
 
Paul


From: ERowe
Posted: 14 December 2011 15:44
Subject: DLL missing when I try to copy Fluid Earth example

Hi Gordon / Adrian

 

I was inspired at the recent Model Fusion meeting to have another go with the Fluid Earth templates and Pipistrelle, so I’ve gone through the videos to set up the TestProject example.

 

When I tried running the TestProject configuration in Pipistrelle, it wasn’t able to find the TestProjectEngine.dll file (see attached log). The solution built without errors, but indeed I can’t find a TestProjectEngine.dll file anywhere either. I’m sure I’ve done something wrong, but rather than start again from scratch I thought I’d see if you have any tips.

 

I couldn’t do everything exactly as instructed, perhaps because my Visual Studio setup is different from the one in the video – my VS configuration is described below. The discrepancies looked minor, apart from:

a)      the code in the embedded.cs that I downloaded is different to the code visible in the video.

b)      When I R-click the TestProject C# project, the Application and Build options are different (see screenshots attached). In particular I wasn’t able to set Build – Configuration – All configurations.

c)       For my TestProject.omi and TestProject.xml files, I set the Build Action to “Embedded resource” by accident, and then was not able to set the Build Action back to <blank> so this is set to “None”.

 

Do you think it might be one of these differences that’s the problem? Or can you suggest a step that I might have missed? I tried to log all the actions in the from the videos in the attached Word file.

 

many thanks

Ed

Attachments
Content Type: Message
Created at 11/01/2012 15:35  by PCleverley 
Last modified at 11/01/2012 15:35  by PCleverley